Colossuscoin2.0's block explorer service expires





  • http://www.presstab.pw/phpexplorer/CV2/index.php

    Colossuscoin2.0's block explorer service expires on Oct 02 2016 and needs to be renewed.

    To add another 1 month of funding to the block explorer send
    0.0116 BTC to 14cVDovAkbSKWVwd1MAeusk6fHA23qVcYG

    QuoteColossuscoin2.0's block explorer service expired on Oct 02 2016

    To add another 1 month of funding to the block explorer send 0.0115 BTC to 14cVDovAkbSKWVwd1MAeusk6fHA23qVcYG

    Contact presstab on bitcointalk to renew for a longer period of time with a lower rate.